Linux Server 向けプログラムをご利用の一部環境にて、Webアクセス保護機能を「無効」に変更した際、通信が遮断される現象についてお問い合わせをいただいております。
本現象の詳細は以下の通りです。
◆ 現象
Red Hat Enterprise Linux / CentOS 7.0 ~ 7.8 の環境にて Linux Server 向けプログラムをご利用の場合、Webアクセス保護機能を既定の「有効」から「無効」に変更した際、通信が遮断される現象が発生します。
◆ 対象製品
- ESET PROTECT Essential クラウド
- ESET PROTECT Entry(旧名称:ESET PROTECT Entry クラウド)
- ESET PROTECT Advanced(旧名称:ESET PROTECT Advanced クラウド)
- ESET PROTECT Complete(旧名称:ESET PROTECT Complete クラウド)
- ESET PROTECT Essential オンプレミス
- ESET PROTECT Entry オンプレミス
- ESET PROTECT Essential Plus オンプレミス
- ESET PROTECT Advanced オンプレミス
- ESET PROTECT MDR Ultimate(旧名称:ESET PROTECT MDR)
- ESET PROTECT MDR Advanced
- ESET PROTECT MDR Lite
- ESET PROTECT Elite
- ESET PROTECT Enterprise
- ESET Server Security for Linux / Windows Server(旧名称:ESET File Security for Linux / Windows Server)
◆ 対象プログラム
- ESET Server Security for Linux V10.1 / V10.2 / V10.3
◆ 対象OS
- Red Hat Enterprise Linux 7.0 ~ 7.8
- CentOS 7.0 ~ 7.8
◆ 原因
Webアクセス保護機能を無効にした際、nftables内のルールが正常に削除されず残存することにより、全ての外向きの通信が無効なポートへリダイレクトされることで発生しております。
◆ 対応策
Red Hat Enterprise Linux / CentOS 7.9 においては発生しないことを確認しております。
Webアクセス保護機能を「無効」にした状態での運用をご希望される場合は、事前にOSのバージョンアップを実施いただきますようお願いいたします。
◆ 暫定回避策
本現象が発生している場合は、OSの再起動を行うことで、現象の回避が可能です。
なお、OS再起動後はWebアクセス保護機能は「無効」状態、および本現象は発生しない状態になりますのでそのままご利用いただけますが、お客さまのご都合の良いタイミングでOSのバージョンアップもご検討ください。
お客さまにはご迷惑をお掛けしておりますことを、深くお詫び申し上げます。